概要
以下の状況の場合の対応方法を記載しています。
- Windowsを利用している
- ラクローの勤怠画面にPCログの情報が反映されない
- ラクローアプリの「動作詳細」をクリックし、動作詳細欄を見ると「送信に失敗しました」「spawn UNKNOWN」と表示される
対応方法
- ラクローアプリを表示し、「歯車アイコン」を押す
- 「確認した上で、編集する」にチェックを入れる
- コマンド設定 > イベントログフィルタの無効化にチェックを入れる
- バッファーサイズを100に変更する
- 「設定する」をクリック(→「設定を保存しました」と表示されます)
- 「ログを送信する」をクリックします。実行には数分かかる場合がございます。
- 「送信完了しました」と表示されれば成功です。
- ラクローWEB画面の勤怠にPCログが反映されているかをご確認ください
- 詳細設定のバッファーサイズは、「5」に設定し直してください。(イベントログフィルタの無効化のチェックは入れたまま戻さないでください)
※ バッファーサイズを「100」に変更しても解消しない場合は、バッファーサイズを「150」→「200」→「250」と変更しながら再度お試しください。問題が解消できた場合は、バッファーサイズを「5」に設定し直してください。
原因
ラクローでは、WindowsのPCログ取得の際に、コマンド内でフィルタをかけて勤怠反映には不必要なログの一部を除去しています。フィルタをかける目的としては、送信するログの量を抑えてパフォーマンスへの影響を小さくすることです。
しかし、PCによって、稀にコマンドのフィルタ部分でエラーが発生してしまう場合があることがわかりました。
そこで、フィルタ部分でエラーが発生してしまうPCに限っては、フィルタを無効化してログ取得をすることでエラーを回避する方針を取ることにいたしました。
フィルタを無効化してログ取得をすると、特に初回連携時はログの量が多過ぎて「ERR_CHILD_PROCESS_STDIO_MAXBUFFER(バッファ不足)」が発生してしまう場合があります。そのため、バッファーサイズについても設定できるようにいたしました。