概要
以下の状況の場合の対応方法を記載しています。
- Windowsを利用している
- ラクローの勤怠画面にPCログの情報が反映されない
- ラクローアプリの「動作詳細」をクリックし、動作詳細欄を見ると「送信に失敗しました」「ERR_CHILD_PROCESS_STDIO_MAXBUFFER」と表示される
対応方法
- ラクローアプリを表示し、「歯車アイコン」を押す
- 「確認した上で、編集する」にチェックを入れる
- コマンド設定 > バッファーサイズを100に変更する
- 「設定する」をクリックする
- 「設定を保存しました」と表示されたらOKをクリックする
- 「ログを送信する」をクリックする ※実行には数分かかる場合がございます
- 「送信完了しました」と表示されれば成功です
- ラクローWEB画面の勤怠にPCログが反映されているかをご確認ください
- 詳細設定のバッファーサイズは、「5」に設定し直してください。
注意事項
- バッファーサイズを「100」に変更しても解消しない場合は、バッファーサイズを「150」→「200」→「250」と変更しながら再度お試しください。問題が解消できた場合は、バッファーサイズを「5」に設定し直してください。
- 「ERR_CHILD_PROCESS_STDIO_MAXBUFFER」のエラーが頻発する場合は、バッファーサイズを「5」に戻さず、大きく設定したままでご使用ください。
ただし、バッファーサイズが大き過ぎるとメモリ不足を起こし、ラクローアプリがフリーズする可能性がございます。そのため、極力小さめのバッファーサイズから設定して様子を見ていただくことを推奨しております。
原因
「ERR_CHILD_PROCESS_STDIO_MAXBUFFER(バッファ不足)」は、PCログ取得の際にログの量が多過ぎることで発生する場合があります。